Sie befinden sich hier im Forenarchiv von phpforum.de wenn Sie direkt ins Forum möchten, klicken Sie bitte hier. Zur Startseite kommen Sie hier.

finde den fehler nicht !

Code:                   In Zwischenablage kopieren (nur IE)
1">

was ist in der zeile falsch ??? ich sehe es einfach nicht
Hier gehts zum Orginal Eintrag "finde den fehler nicht !" im Forum

Antworten

kann man die if abfrage so in dem echo befehl verschachteln? waere mir neu. trenn das mal auf in:

echo " <td width=\"190\" height=\"23\" align=\"left\" valign=\"top\"><input type=\"text\" style=\"width:170\" maxlength=\"60\" name=\"location\" id=\"location\" class=\"input\" ";
if(isset($_REQUEST['location'])){
echo "value=\"".$_REQUEST['location']."\"";
}
echo " /></td>\n";


2.

Das if gehört auf jeden Fall raus, vielleicht willst Du stattdessen lieber den Operator a?b:c verwenden.


3.

danke.. das habe ich vorhin auch schon probiert aber ich hatte dann wieder ein parse und habs nicht gesehen *grrr*. das es mit dem if wusste ich nicht und dachte wenn dann wird mir einer das schon hier sagen, war ein versuch ;) !!

vielleicht kannst mir mal noch was verraten:

ich möchte ja die daten in einem formular die schon eingetragen wurden nach einem check erhalten nur irgendwie will das nicht so richtig funzen !

ich hab das so das ich ne if-abfrage habe die festellt ob isset($_post ..... und wenn nicht dann }else{ und das fomular wird angezeigt. wenn dann doch die daten anliegen prüft er diese und schreibt mir dann ne fehlermeldung wo ich dann zurück zum formular per link komme... nur dann stehe keine daten mehr in den feldern !!!

hast da einen tip ?? wie sende ich die wieder zurück ???


4.

so gar nicht, du musst das Formuarl komplett neu aufbauen, nur diesmal mit den Werten vorbelegt, die du in den POST-Feldern stehen hast.


5.

wie komplett neuaufbauen ??? verstehe da nicht ganze den genauen hintergrund ??


6.

Das Thema wurde hier aber schon oft diskutiert, deswegen verweise ich jetzt einfach mal auf die Suchmöglichkeiten des Forums.


Hier gehts zum Orginal Eintrag "finde den fehler nicht !" im Forum
 
phpforum.de | Impressum