Sie befinden sich hier im Forenarchiv von phpforum.de wenn Sie direkt ins Forum möchten, klicken Sie bitte hier. Zur Startseite kommen Sie hier.

Frameprobleme?!?

Hi!
Ich hab atm ein etwas kniffligeres Problem mit meinem PHP, aber um dahin zu kommen brauch ich vorher noch ne Lösung für folgendes:

Ich hab zwei Seiten:
Die index.html

Code:                   In Zwischenablage kopieren (nur IE)
1">

und die mainframe.html
Code:                   In Zwischenablage kopieren (nur IE)
2">

Jetzt hab ich in meiner sprache.php ein paar Flaggen die eine Variable übergeben "können", anhand derer sich die Sprache für meine HP einstellen lässt. Da die Sprachvariable aber (meines Wissens nach) nur für das angesprochene Script gültig ist, wollte ich gleich ein ganzes Frameset verlinken, in der Hoffnung, das die Variable an beide Seiten übergeben wird.
Wenn dem nicht so ist, sagt mir dass ich mich gleich wieder hinlegen kann!! :D

Ansonsten hab ich jetzt das Problem, dass er den Link
(Bsp: < a href="./mainframe.php?lang=deu" target="bothframes"><img src="./lang/deu.jpg" border="0">< /a >)
nicht im "bothframes" aufmacht, sondern ein neues Fenster öffnet und dabei auch noch die menue.php vergisst...

Ich hoffe es ist mal wieder eine Lapalie!
Aber es wäre nett, wenn mir jemand die Augen öffnet! ;)

MfG,
Oliver
Hier gehts zum Orginal Eintrag "Frameprobleme?!?" im Forum

Antworten

Du kannst dich halb hinlegen. Die übergabe geht definitiv nicht automatisch, aber du kannst das Frameset von PHP erzeugen lassen und dann damit deine Parameter an die URLs anhängen.


2.

Kannst du mir da mal etwas auf die Sprünge helfen, wo ich die Vars anhängen soll?

Meinst du
Code:                   In Zwischenablage kopieren (nur IE)
3">

?


Hier gehts zum Orginal Eintrag "Frameprobleme?!?" im Forum
 
phpforum.de | Impressum | Handy Bundles