Sie befinden sich hier im Forenarchiv von phpforum.de wenn Sie direkt ins Forum möchten, klicken Sie bitte hier. Zur Startseite kommen Sie hier.

Probleme mit Phpsessid

Hi,

ich habe ein riesiges Problem mit meinen Session-IDs:

Ich habe eine PHP-Seite, auf der nur folgender Code steht:

Code:                   In Zwischenablage kopieren (nur IE)
1">

Aber als Ausgabe erhalte ich immer nur folgendes:

Code:                   In Zwischenablage kopieren (nur IE)
2">

Ich bekomme immer nur diese Fehlermeldung, die Session-ID wird nicht ausgegeben.

Woran kannt das liegen? Ich habe keine Ahnung!

Vielen dank für Eure Hilfe!!!
Hier gehts zum Orginal Eintrag "Probleme mit Phpsessid" im Forum

Antworten

Hier im Forum gibts ne Suche
Mit dem Begriff "headers already sent " findest du ne ganze Menge...


2.

Zitat:
Foggy postete
Hier im Forum gibts ne Suche
Mit dem Begriff "headers already sent " findest du ne ganze Menge...
aber wieso wird mir gesagt, das die SESSION-ID ungültig ist, wenn sie Server erzeugt wird?


3.

Hast du in 2 MInuten die Suchfunktion des Forums benutzt und dir die Ergebnisse angeschaut????????????


4.

Haha
Darf ich dich verlinken da dus selber anscheinend nicht findest:
http://www.phpforum.de/forum/showtopic.php?threadid=32116&time=1107378408&pagenum=lastpage


5.

Habe ich.
Ich bekomme nur 6 Themen angezeigt.

Das Problem mit den Session wir aber nicht erläutert


6.

Also ich bekomm hundert Treffer....
So und alle laufen darauf hinaus das man keinerlei Ausgaben an den Browser machen darf bevor man zB
heder ("location.... , session_start(), usw aufruft, denn sonst kommt besagte Fehlermeldung ;)


7.

was kommt den wenn du nur session_start() in das Skript rein schreibst???

ist session_start() direkt am Anfang des Skriptes also die erste Zeil in der Datei???
weil session_start() am Anfang stehen muss

[doc]session_start[/doc]


8.

man warst schneller... ;)


9.

Zitat:
liebesKerlchen postete
was kommt den wenn du nur session_start() in das Skript rein schreibst???

ist session_start() direkt am Anfang des Skriptes also die erste Zeil in der Datei???
weil session_start() am Anfang stehen muss

[doc]session_start[/doc]
es passiert das gleiche!

Außerdem, das echo steht doch hinter session_start();, davor steht absolut garnichts.


Hier gehts zum Orginal Eintrag "Probleme mit Phpsessid" im Forum
 
phpforum.de | Impressum