Sie befinden sich hier im Forenarchiv von phpforum.de wenn Sie direkt ins Forum möchten, klicken Sie bitte hier. Zur Startseite kommen Sie hier.

delete wird nicht ausgeführt

Hi,

Ich habe in den Benutzereinstellungen einen weiteren Button gemacht was sich "Acc löschen" nennt, dort kann man "Ja" oder "Nein" angeben.

Wenn man "Ja" angibt schickt das System eine E-Mail mit einem kleinen Text und einem löschlink an die angebenene E-Mail Addi.

Nur der Link der angegeben ist zum Acc löschen funzt nicht.

Ich hoffe ihr könnt mir weiterhelfen

Hier der Code der "Delete.php" / Überall wo "GameName" steht kommt der Name rein

Code:                   In Zwischenablage kopieren (nur IE)
1">

Hier gehts zum Orginal Eintrag "delete wird nicht ausgeführt" im Forum

Antworten

if(isset($_POST['delete_button'])) ? :) ?


2.

An den Anfang des Scriptes gehöhrt ein:
Code:                   In Zwischenablage kopieren (nur IE)
2">

Das sollte dir einige Fehler zeigen.


auch irgendwo im Script
Code:                   In Zwischenablage kopieren (nur IE)
3">

würde nicht schaden.



$delete_button soll aus den Form Daten gefüllt werden. Richtig?
Submit gedrückt!

Ist bei Dir register_globals auf off? Wenn ja, dann so lassen!
In dem Fall mußt Du das $_POST Array nutzen um an deine
Form Daten zu kommen.

Es ist evtl besser $_REQUEST durch $_POST, $_GET oder $_COOKIE zu ersetzen
Je nachdem woher die Daten nun wirklich erwartet werden.



http://de3.php.net/manual/de/ini.sect.data-handling.php#ini.register-globals
http://de3.php.net/manual/de/language.variables.predefined.php#language.variables.superglobals


Hier gehts zum Orginal Eintrag "delete wird nicht ausgeführt" im Forum
 
phpforum.de | Impressum