Sie befinden sich hier im Forenarchiv von phpforum.de wenn Sie direkt ins Forum möchten, klicken Sie bitte hier. Zur Startseite kommen Sie hier.

Probleme mit Ajax - Post

Heyho,

ich hab gerade ein Problem mit Ajax. Ich möchte eine Post-Anforderung an den Server senden, allerdings kommt dort nicht an. Wieso ist mir unerklärlich.

Codeauszüge in vereinfachter Form:

Html - Form

Code:                   In Zwischenablage kopieren (nur IE)
1">

JS/Ajax Code:
Code:                   In Zwischenablage kopieren (nur IE)
2">

So, nun kommt in der streams.php aber kein Post an. Warum??

Vielen Dank für eure Hilfe,
der Jörchen
Hier gehts zum Orginal Eintrag "Probleme mit Ajax - Post" im Forum

Antworten

Wo initialisierst du denn deinen HTTP Handler ?

Benutze lieber ein Framework wie z.B. SAJAX.


2.

das ist mein HTTP Handler

Code:                   In Zwischenablage kopieren (nur IE)
3">

Aber SAJAX hört sich gut an, ich schaue mir das gerade an. Ich glaube darauf werde ich umsteigen, da mann doch schneller Strukturen aufbauen kann.

Vielen Dank und Grüße


3.

Also dein Handleraufbau gefällt mir gar nicht. Ich würde den eher so gestalten:

Code:                   In Zwischenablage kopieren (nur IE)
4">




4.

kk, den Request hab ich geändert. Aber es funktioniert leider immer noch nicht.


5.

sry für doppelpost. aber es funktioniert immer noch nicht :(


6.

probier mal xajax - ist recht einfach:

http://wiki.xajaxproject.org/Tutorials:Learn_xajax_in_10_Minutes


Hier gehts zum Orginal Eintrag "Probleme mit Ajax - Post" im Forum
 
phpforum.de | Impressum