Sie befinden sich hier im Forenarchiv von phpforum.de wenn Sie direkt ins Forum möchten, klicken Sie bitte hier. Zur Startseite kommen Sie hier.

php - fehlermeldung

hi,

unten angeführtes script hat lange zeit einwandfrei funktioniert. Ohne daran etwas zu verändern kommen jetzt folgende fehlermeldungen :

Warning: Unknown(http://************/dummy-3.7.0/typo3conf/ext/ligamanager/lmo/lmo_viewer.php): failed to open stream: HTTP request failed! HTTP/1.1 500 Internal Server Error in /www/htdocs/*****/dummy-3.7.0/typo3conf/ext/page_php_content/pi1/class.tx_pagephpcontent_pi1.php(55) : eval()'d code on line 1

Warning: Unknown(http://************/dummy-3.7.0/typo3conf/ext/ligamanager/lmo/lmo_viewer.php): failed to open stream: HTTP request failed! HTTP/1.1 500 Internal Server Error in /www/htdocs/*****/dummy-3.7.0/typo3conf/ext/page_php_content/pi1/class.tx_pagephpcontent_pi1.php(55) : eval()'d code on line 1

Warning: (null)() [function.include]: Failed opening 'http://************/dummy-3.7.0/typo3conf/ext/ligamanager/lmo/lmo_viewer.php' for inclusion (include_path='.:/usr/share/php:..') in /www/htdocs/*****/dummy-3.7.0/typo3conf/ext/page_php_content/pi1/class.tx_pagephpcontent_pi1.php(55) : eval()'d code on line 1

Woran könnte es liegen ???

vielen dank im voraus !

Hier gehts zum Orginal Eintrag "php - fehlermeldung" im Forum

Antworten

Welches Script ? Und als "fortgeschrittener Programmierer" sollte man ja mit Fehlermeldungen zu Recht kommen können, daher schiebe ich mal ins Anfängerforum.

Anscheinend hast du oder ein anderer am Server rumgespielt, da es zu einem "Internal Server Error" kommt ...


2.

wo du das script hinschiebst ist für mich nicht so wichtig.

meinerseits wurden keine änderungen am server vorgenommen. weder php.ini noch .htaccess geändert.
kann diese fehlermeldung durch einen upgrade auf eine neuere php version entstehen ?

wenn ich in die htaccess datei folgendes reinschreibe :
AddHandler php-fastcgi .php .php4

kommt statt der oben angeführten fehlermeldung folgende :
Fatal error: Call to a member function on a non-object in /www/htdocs/kuegerl/dummy-3.7.0/tslib/class.tslib_fe.php on line 388

habe im internet nicht wirklich lösungsansätze finden können ...

bitte um weitere hinweise !


3.

Ja, das kann es durchaus sein ? Aber von welchem Script redest du ?


4.

Rufe mal
http://************/dummy-3.7.0/typo3conf/ext/ligamanager/lmo/lmo_viewer.php
im Browser auf und schau ob da was gescheites steht..
Meistens kommt ein 500er Fehler durch eine falsche htaccess, also schau mal ob in irgendeinem verzeichnis auf dem weg nach http://************/dummy-3.7.0/typo3conf/ext/ligamanager/lmo/lmo_viewer.php eine htaccess rumliegt..
Ansonsten nachschauen in den Server-Logs, falls du da rankommst..


5.

@BenniG
danke vielmals. fehler gefunden !
auf dem weg in oben beschriebenes verzeichnis war eine .htaccess datei versteckt, die diese fehlermeldung ausgelöst hat.

übrigens : auf meinem server wurde ein sicherheitsupdate durchgeführt. dadurch wurde das ganze anscheinend ausgelöst. zuvor machte diese datei keine probleme....

danke !

@johnpatcher : rede von dem script, das eigentlich post heißen sollte.


Hier gehts zum Orginal Eintrag "php - fehlermeldung" im Forum
 
phpforum.de | Impressum