Sie befinden sich hier im Forenarchiv von phpforum.de wenn Sie direkt ins Forum möchten, klicken Sie bitte hier. Zur Startseite kommen Sie hier.

$_server['php_self']

Hallo

Ich hab auf einer php seite ein form wo ich also action fogendes eingebe:

Code:                   In Zwischenablage kopieren (nur IE)
1">

aber um zuerst auf dies seite zu gelangen ging es ueber ein link und jetzt steht dann oben Folder/?mod=true&index=20

Aber wenn ich jetzt den submit button im oberen form druecke moechte ich auf auf Folder/ gelangen aber der PHP_SELF gibt immer wieder Folder/?mod=true&index=20. Gibt es da eine andere methode die ich verwenden kann ausser "./" oder den Namen der Datei moechte es schon gern dynamisch :)

MfG Dany
Hier gehts zum Orginal Eintrag "$_server['php_self']" im Forum

Antworten

Zitat:
aber der PHP_SELF gibt immer wieder Folder/?mod=true&index=20
glaube ich nicht!!!
Wo sollen denn die Get Daten bei einem Formular herkommen??

Du meinst bestimmt:
Code:                   In Zwischenablage kopieren (nur IE)
2">




2.

Code:                   In Zwischenablage kopieren (nur IE)
3">




3.

Zitat:
glaube ich nicht!!!
Ich schon - weil ein Gleichheitszeichen (oder echo) fehlt...


4.

Zitat:
Rana postete
Zitat:
glaube ich nicht!!!
Ich schon - weil ein Gleichheitszeichen (oder echo) fehlt...
Nein ! (Ja klar, das echo oder = fehlt!!)
In $_SERVER['PHP_SELF'] steht schon das richtige!!
Es ist der Browser, der den Get Krams dahin klatscht..


5.

Zitat:
Es ist der Browser, der den Get Krams dahin klatscht..
Joo - ich rate einfach mal, da steht "in echt" gar nicht method="post"... (nur hier für uns).


6.

Hmmmm..
Es könnte auch sein, daß sich der Broweser gezwungen sieht die "letzte" Url zu verwenden,
weil ja das action Attribut des Formtags, wegen des fehlenden echos, leer bleibt...


7.

Stimmt! Klingt auch gut. So oder so schrottig...


8.

Danke fuer all die antworten

Jep hatte den echo nicht da stehen :( sorry
Aber danke fuer eure Hilfe


Hier gehts zum Orginal Eintrag "$_server['php_self']" im Forum
 
phpforum.de | Impressum