Sie befinden sich hier im Forenarchiv von phpforum.de wenn Sie direkt ins Forum möchten, klicken Sie bitte hier. Zur Startseite kommen Sie hier.

for- Schleife liefter falschen Wert, wieso?

Code:                   In Zwischenablage kopieren (nur IE)
1">

Das Problem ist nun folgendes: Sobald ${"geb"."$a"}[$b] != 0 rechnet er im else nicht c++. Das Problem kann ja mehr oder weniger nur an der Schreibweise liegen. Ich muss den Wert dort an der Stelle -1 rechnen (dauert jetzt zu lange zum erklären) , aber bitte wieso macht er das nicht so?

Das ist das Problemkind: [color="red"]if($u_geb[${"geb"."$a"}[$b]-1] != 0)[/color]

mfg thomas
Hier gehts zum Orginal Eintrag "for- Schleife liefter falschen Wert, wieso?" im Forum

Antworten

1. was soll das Script überhaupt bewirken...
2. kannst du nicht besser auf die variablen Variabeln verzichten?


2.

Code:                   In Zwischenablage kopieren (nur IE)
2">

narürlich wird im else-Teil c++ nur ausgeführt wenn die if-Bedingung erfüllt ist.

Debuggen ?

Standard-Antwort:
Richtig debuggen
1. Man bemerkt, dass ein Skript nicht das tut, was es soll.
2. Man versucht, die Stelle die daran Schuld sein kann, schonmal einzugrenzen. Falls dies nicht geht, wird zunächst das komplette Skript als fehlerhaft angesehen.
3. An den Anfang des Scriptes schreibt man die Zeile: error_reporting(E_ALL);
4. An markanten Stellen im Skript lässt man sich wichtige Variableninhalte ausgeben und ggf. auch in bedingten Anweisungen eine kurze Ausgabe machen, um zu überprüfen, welche Bedingung ausgeführt wurde (oder auch nicht).
5. Schritt 4 wird so lange wiederholt, bis Unstimmigkeiten im Skript auffallen
6. Damit hat man das Problem (Unstimmigkeit) gefunden und kann versuchen diese zu beheben. Hierzu dienen dann die PHP-Dokumentation und andere Quellen als Ratgeber.
7. Lässt sich das konkrete Problem trotzdem nicht beheben, kann man in Foren um Rat fragen.
8. Das Programm läuft und man kann die Debug-Ausgaben wieder entfernen.

Die Ausgaben per echo kann man sich ersparen, in dem man einen Debugger benutzt.


Hier gehts zum Orginal Eintrag "for- Schleife liefter falschen Wert, wieso?" im Forum
 
phpforum.de | Impressum