Suchen
Inside Forum
Nützliche Links




 
phpforum.de bei Facebook
 
phpforum.de bei Twitter
 

Zurück   PHP Forum: phpforum.de > Server > Administration

Administration Alles rund um den Betrieb und die Konfiguration eigener Server (Apache, mod_rewrite, etc.)

Antwort
 
Themen-Optionen Ansicht
  #1  
Alt 09.08.2017, 17:16
rammi22 rammi22 ist offline
Engagierter Besucher
 
Registriert seit: 11.03.2011
Ort: Berlin, Deutschland
Beiträge: 820
Standard Debian Apache2 Weiterleitung zum Path funktioniert nicht

Hallo,
in einer virtuellen Maschine lass ich Debian 9 stretch laufen (apache2, php7.0.*)

Der Versuch eine lokale Unterseite aufzurufen scheitert schon daran, das die Anfrage nicht mal ins die index.php kommt:

index.php
PHP Quellcode:
<?php
var_dump($_SERVER);
die();
...
?>

...
Ausgabe: xxx.local
HTML Quellcode:
.../index.php:4:
array (size=69)
  'HTTPS' => string 'on' (length=2)
 ...

Ausgabe: xxx.local/de/
HTML Quellcode:
Not Found
 
The requested URL /de/ was not found on this server.
_______________________________________
Apache/2.4.25 (Debian) Server at xxx.local Port 443

Warum kann der Apache nicht auf dem Pfad /de/ zugreifen?
__________________
Gruss Rammi

Win 7 PRO || PostgreSQL 9.3.4, compiled by Visual C++ build 1600, 32-bit || XAMPP 1.8.1 || PHP: 5.4.7 || PSPad 4.5.7
Mit Zitat antworten
  #2  
Alt 09.08.2017, 17:31
Kasalop Kasalop ist gerade online
Forum-Mitarbeiter
 
Registriert seit: 29.12.2006
Ort: München
Beiträge: 5.710
Standard AW: Debian Apache2 Weiterleitung zum Path funktioniert nicht

Wie ist denn deine Ordnerstruktur? Wo befinden sich welche Dateien?
__________________
Es gibt 10 Arten von Menschen auf der Welt. Die die die binäre Mathematik verstehen und die die sie nicht verstehen!

Zu welcher der Gruppen gehörst du?
Mit Zitat antworten
  #3  
Alt 09.08.2017, 18:47
Don T. Worry Don T. Worry ist offline
Engagierter Besucher
 
Registriert seit: 29.03.2012
Beiträge: 497
Standard AW: Debian Apache2 Weiterleitung zum Path funktioniert nicht

Zitat:
in einer virtuellen Maschine
Achtung, virtuelle Maschinen mappen nicht automatisch auf das externe Dateisystem.
__________________
“Just think of how stupid the average person is, and then realize half of them are even stupider!” [George Carlin]

“There is only one god, and His name is Death. And there is only one thing we say to Death: "not today".” [Syrio Forel]
Mit Zitat antworten
  #4  
Alt 09.08.2017, 20:05
quantor quantor ist offline
Engagierter Besucher
 
Registriert seit: 25.10.2012
Beiträge: 3.101
Standard AW: Debian Apache2 Weiterleitung zum Path funktioniert nicht

Zitat:
Zitat von rammi22 Beitrag anzeigen
The requested URL /de/ was not found on this server.
_______________________________________
Apache/2.4.25 (Debian) Server at xxx.local Port 443
[/HTML]
Warum kann der Apache nicht auf dem Pfad /de/ zugreifen?
Das er nicht zugreifen kann steht da nicht. Sondern der Pfad existiert nicht an der Stelle, wo du das Wurzelverzeichnis hast.
Mit Zitat antworten
  #5  
Alt 10.08.2017, 10:18
rammi22 rammi22 ist offline
Engagierter Besucher
 
Registriert seit: 11.03.2011
Ort: Berlin, Deutschland
Beiträge: 820
Standard AW: Debian Apache2 Weiterleitung zum Path funktioniert nicht

Zitat:
Zitat von Kasalop Beitrag anzeigen
Wie ist denn deine Ordnerstruktur? ...?
Sämtliche Anfragen werden über die index.php geschickt.Und die URI ohne Pfad funktioniert ja auch...

Die ganze Applikation basiert auf einem SilexFramework:

|- Applikation
|-- app
|-- htdocs
|--- .htaccess
|--- index.php
|--- ...
|-- src
|-- vendor

.htaccess:
HTML Quellcode:
<IfModule mod_rewrite.c>
    Options -MultiViews

    RewriteEngine On
    RewriteBase /

  RewriteCond %{HTTPS} !=on
  RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

    # RewriteCond %{REQUEST_FILENAME} !-f
    # RewriteCond %{REQUEST_URI} !(.+)/$
    # RewriteRule ^(.+)$ $1/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} !-f
  RewriteRule ^ index.php [L,QSA]
</IfModule>
__________________
Gruss Rammi

Win 7 PRO || PostgreSQL 9.3.4, compiled by Visual C++ build 1600, 32-bit || XAMPP 1.8.1 || PHP: 5.4.7 || PSPad 4.5.7

Geändert von rammi22 (10.08.2017 um 10:24 Uhr)
Mit Zitat antworten
  #6  
Alt 10.08.2017, 10:34
rammi22 rammi22 ist offline
Engagierter Besucher
 
Registriert seit: 11.03.2011
Ort: Berlin, Deutschland
Beiträge: 820
Standard AW: Gelöst!

Es war die mode_rewrite nicht an, hab ich erst bemerkt beim schreiben des obigen Beitrages...

Vielen Dank
__________________
Gruss Rammi

Win 7 PRO || PostgreSQL 9.3.4, compiled by Visual C++ build 1600, 32-bit || XAMPP 1.8.1 || PHP: 5.4.7 || PSPad 4.5.7
Mit Zitat antworten


Antwort

Lesezeichen

Themen-Optionen
Ansicht

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.

Gehe zu
Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
weiterleitung funktioniert nicht so... internetdepp PHP 3 02.07.2013 16:31
Apache2 SSLVerifyClient funktioniert nicht! Fatzke81 Administration 3 18.07.2010 23:35
Weiterleitung mit PHP funktioniert nicht Domzilla PHP 4 20.08.2007 18:31
Weiterleitung funktioniert nicht Remzi PHP 15 13.12.2006 14:23
weiterleitung im htaccess mit Ie nicht funktioniert ?!?!? sergio Sonstiges 1 09.01.2005 14:00


Alle Zeitangaben in WEZ +2. Es ist jetzt 20:27 Uhr.


Powered by vBulletin® Version 3.8.8 (Deutsch)
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Powered by NuWiki v1.3 RC1 Copyright ©2006-2007, NuHit, LLC